const regex = /(?:Subject\:)(?:[\r\n]{2})(?<Subject>.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Subject\\:)(?:[\\r\\n]{2})(?<Subject>.+)', 'g')
const str = `Subject:
Object reference not set to an instance of an object.
Created On (UTC): 6/26/2017 3:03:03 PM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}