#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!SaaS)(?i)saas\b"
Local $sString = "SaaS" & @CRLF & _
"Saas" & @CRLF & _
"SaAs" & @CRLF & _
"SaAS" & @CRLF & _
"SAas" & @CRLF & _
"SAaS" & @CRLF & _
"SAAs" & @CRLF & _
"SAAS" & @CRLF & _
"saas" & @CRLF & _
"saaS" & @CRLF & _
"saAs" & @CRLF & _
"saAS" & @CRLF & _
"sAas" & @CRLF & _
"sAaS" & @CRLF & _
"sAAs" & @CRLF & _
"sAAs" & @CRLF & _
"It's SaaS, not SAas or saAS or sAAs, you dummy" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")