re = /\b(?!SaaS)(?i)saas\b/m
str = 'SaaS
Saas
SaAs
SaAS
SAas
SAaS
SAAs
SAAS
saas
saaS
saAs
saAS
sAas
sAaS
sAAs
sAAs
It\'s SaaS, not SAas or saAS or sAAs, you dummy
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end