import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!SaaS)(?i)saas\\b";
final String string = "SaaS\n"
+ "Saas\n"
+ "SaAs\n"
+ "SaAS\n"
+ "SAas\n"
+ "SAaS\n"
+ "SAAs\n"
+ "SAAS\n"
+ "saas\n"
+ "saaS\n"
+ "saAs\n"
+ "saAS\n"
+ "sAas\n"
+ "sAaS\n"
+ "sAAs\n"
+ "sAAs\n"
+ "It's SaaS, not SAas or saAS or sAAs, you dummy\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}