const regex = /\b(?!SaaS)(?i)saas\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!SaaS)(?i)saas\\b', 'gm')
const str = `SaaS
Saas
SaAs
SaAS
SAas
SAaS
SAAs
SAAS
saas
saaS
saAs
saAS
sAas
sAaS
sAAs
sAAs
It's SaaS, not SAas or saAS or sAAs, you dummy
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}