$re = '/\b(?!SaaS)(?i)saas\b/m';
$str = 'SaaS
Saas
SaAs
SaAS
SAas
SAaS
SAAs
SAAS
saas
saaS
saAs
saAS
sAas
sAaS
sAAs
sAAs
It\'s SaaS, not SAas or saAS or sAAs, you dummy
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);