package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]+`)
var str = `0_topo
1_rigid
00_topo
01_rigid
000_topo
003_capri
topo
log
capri
else`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}