import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+";
final String string = "0_topo\n"
+ "1_rigid\n"
+ "00_topo\n"
+ "01_rigid\n"
+ "000_topo\n"
+ "003_capri\n"
+ "topo\n"
+ "log\n"
+ "capri\n"
+ "else";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}