re = /[0-9]+/m
str = '0_topo
1_rigid
00_topo
01_rigid
000_topo
003_capri
topo
log
capri
else'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end