import re
regex = re.compile(r"[0-9]+", flags=re.MULTILINE)
test_str = ("0_topo\n"
"1_rigid\n"
"00_topo\n"
"01_rigid\n"
"000_topo\n"
"003_capri\n"
"topo\n"
"log\n"
"capri\n"
"else")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")