$re = '/[0-9]+/m';
$str = '0_topo
1_rigid
00_topo
01_rigid
000_topo
003_capri
topo
log
capri
else';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);