#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(?<!<br>)(?:<br>){0,1}\[trigger\](.+?)\[\/trigger\](?:<br>){0,1}(?!<br>)"
Local $sString = "At vero eos et accusamus et iusto [trigger]odio dignissimos ducimus qui blanditiis " & @CRLF & _
"" & @CRLF & _
"praesentium voluptatum " & @CRLF & _
"deleniti atque corrupti quos[/trigger]<br> dolores et quas molestias " & @CRLF & _
"excepturi sint occaecati cupiditate non provident, similique sunt in culpa qui officia deserunt mollitia animi, id est laborum et dolorum fuga. Et harum quidem rer" & @CRLF & _
"" & @CRLF & _
"um facilis est et expedita distinctio. " & @CRLF & _
"" & @CRLF & _
"...<br>[trigger]Nam<br>lib[/trigger]<br>..." & @CRLF & _
"" & @CRLF & _
"ero tempore, cum soluta nobis est eligendi optio cumque<br>[trigger]nihil impedit " & @CRLF & _
"quo minus <br><br>" & @CRLF & _
"id quod maxime <br>" & @CRLF & _
"placeat <br><br>" & @CRLF & _
"facere[/trigger] possimus, omnis voluptas assumenda est, " & @CRLF & _
"omnis dolor repellendus. Temporibus autem quibusdam et aut officiis debitis aut " & @CRLF & _
"" & @CRLF & _
"[trigger]rerum necessitatibus saepe eveniet ut et voluptates repudiandae " & @CRLF & _
"" & @CRLF & _
"<br><br>[trigger]Internal[/trigger]" & @CRLF & _
"non recusandae[/trigger]<br>" & @CRLF & _
"sint et molestiae. " & @CRLF & _
"Itaque earum rerum hic [trigger]To win[/trigger] tenetur a sapiente delectus, ut aut reiciendis voluptatibus maiores alias consequatur aut perferendis doloribus asperiores repellat" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")