use strict;
my $str = 'At vero eos et accusamus et iusto [trigger]odio dignissimos ducimus qui blanditiis
praesentium voluptatum
deleniti atque corrupti quos[/trigger]<br> dolores et quas molestias
excepturi sint occaecati cupiditate non provident, similique sunt in culpa qui officia deserunt mollitia animi, id est laborum et dolorum fuga. Et harum quidem rer
um facilis est et expedita distinctio.
...<br>[trigger]Nam<br>lib[/trigger]<br>...
ero tempore, cum soluta nobis est eligendi optio cumque<br>[trigger]nihil impedit
quo minus <br><br>
id quod maxime <br>
placeat <br><br>
facere[/trigger] possimus, omnis voluptas assumenda est,
omnis dolor repellendus. Temporibus autem quibusdam et aut officiis debitis aut
[trigger]rerum necessitatibus saepe eveniet ut et voluptates repudiandae
<br><br>[trigger]Internal[/trigger]
non recusandae[/trigger]<br>
sint et molestiae.
Itaque earum rerum hic [trigger]To win[/trigger] tenetur a sapiente delectus, ut aut reiciendis voluptatibus maiores alias consequatur aut perferendis doloribus asperiores repellat
';
my $regex = qr/(?<!<br>)(?:<br>){0,1}\[trigger\](.+?)\[\/trigger\](?:<br>){0,1}(?!<br>)/isp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}