import Foundation
let pattern = #"(?<!<br>)(?:<br>){0,1}\[trigger\](.+?)\[\/trigger\](?:<br>){0,1}(?!<br>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
At vero eos et accusamus et iusto [trigger]odio dignissimos ducimus qui blanditiis
praesentium voluptatum
deleniti atque corrupti quos[/trigger]<br> dolores et quas molestias
excepturi sint occaecati cupiditate non provident, similique sunt in culpa qui officia deserunt mollitia animi, id est laborum et dolorum fuga. Et harum quidem rer
um facilis est et expedita distinctio.
...<br>[trigger]Nam<br>lib[/trigger]<br>...
ero tempore, cum soluta nobis est eligendi optio cumque<br>[trigger]nihil impedit
quo minus <br><br>
id quod maxime <br>
placeat <br><br>
facere[/trigger] possimus, omnis voluptas assumenda est,
omnis dolor repellendus. Temporibus autem quibusdam et aut officiis debitis aut
[trigger]rerum necessitatibus saepe eveniet ut et voluptates repudiandae
<br><br>[trigger]Internal[/trigger]
non recusandae[/trigger]<br>
sint et molestiae.
Itaque earum rerum hic [trigger]To win[/trigger] tenetur a sapiente delectus, ut aut reiciendis voluptatibus maiores alias consequatur aut perferendis doloribus asperiores repellat
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)