# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!<br>)(?:<br>){0,1}\[trigger\](.+?)\[\/trigger\](?:<br>){0,1}(?!<br>)"
test_str = ("At vero eos et accusamus et iusto [trigger]odio dignissimos ducimus qui blanditiis \n\n"
"praesentium voluptatum \n"
"deleniti atque corrupti quos[/trigger]<br> dolores et quas molestias \n"
"excepturi sint occaecati cupiditate non provident, similique sunt in culpa qui officia deserunt mollitia animi, id est laborum et dolorum fuga. Et harum quidem rer\n\n"
"um facilis est et expedita distinctio. \n\n"
"...<br>[trigger]Nam<br>lib[/trigger]<br>...\n\n"
"ero tempore, cum soluta nobis est eligendi optio cumque<br>[trigger]nihil impedit \n"
"quo minus <br><br>\n"
"id quod maxime <br>\n"
"placeat <br><br>\n"
"facere[/trigger] possimus, omnis voluptas assumenda est, \n"
"omnis dolor repellendus. Temporibus autem quibusdam et aut officiis debitis aut \n\n"
"[trigger]rerum necessitatibus saepe eveniet ut et voluptates repudiandae \n\n"
"<br><br>[trigger]Internal[/trigger]\n"
"non recusandae[/trigger]<br>\n"
"sint et molestiae. \n"
"Itaque earum rerum hic [trigger]To win[/trigger] tenetur a sapiente delectus, ut aut reiciendis voluptatibus maiores alias consequatur aut perferendis doloribus asperiores repellat\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.