using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!<br>)(?:<br>){0,1}\[trigger\](.+?)\[\/trigger\](?:<br>){0,1}(?!<br>)";
string input = @"At vero eos et accusamus et iusto [trigger]odio dignissimos ducimus qui blanditiis
praesentium voluptatum
deleniti atque corrupti quos[/trigger]<br> dolores et quas molestias
excepturi sint occaecati cupiditate non provident, similique sunt in culpa qui officia deserunt mollitia animi, id est laborum et dolorum fuga. Et harum quidem rer
um facilis est et expedita distinctio.
...<br>[trigger]Nam<br>lib[/trigger]<br>...
ero tempore, cum soluta nobis est eligendi optio cumque<br>[trigger]nihil impedit
quo minus <br><br>
id quod maxime <br>
placeat <br><br>
facere[/trigger] possimus, omnis voluptas assumenda est,
omnis dolor repellendus. Temporibus autem quibusdam et aut officiis debitis aut
[trigger]rerum necessitatibus saepe eveniet ut et voluptates repudiandae
<br><br>[trigger]Internal[/trigger]
non recusandae[/trigger]<br>
sint et molestiae.
Itaque earum rerum hic [trigger]To win[/trigger] tenetur a sapiente delectus, ut aut reiciendis voluptatibus maiores alias consequatur aut perferendis doloribus asperiores repellat
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}