import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!<br>)(?:<br>){0,1}\\[trigger\\](.+?)\\[\\/trigger\\](?:<br>){0,1}(?!<br>)";
final String string = "At vero eos et accusamus et iusto [trigger]odio dignissimos ducimus qui blanditiis \n\n"
+ "praesentium voluptatum \n"
+ "deleniti atque corrupti quos[/trigger]<br> dolores et quas molestias \n"
+ "excepturi sint occaecati cupiditate non provident, similique sunt in culpa qui officia deserunt mollitia animi, id est laborum et dolorum fuga. Et harum quidem rer\n\n"
+ "um facilis est et expedita distinctio. \n\n"
+ "...<br>[trigger]Nam<br>lib[/trigger]<br>...\n\n"
+ "ero tempore, cum soluta nobis est eligendi optio cumque<br>[trigger]nihil impedit \n"
+ "quo minus <br><br>\n"
+ "id quod maxime <br>\n"
+ "placeat <br><br>\n"
+ "facere[/trigger] possimus, omnis voluptas assumenda est, \n"
+ "omnis dolor repellendus. Temporibus autem quibusdam et aut officiis debitis aut \n\n"
+ "[trigger]rerum necessitatibus saepe eveniet ut et voluptates repudiandae \n\n"
+ "<br><br>[trigger]Internal[/trigger]\n"
+ "non recusandae[/trigger]<br>\n"
+ "sint et molestiae. \n"
+ "Itaque earum rerum hic [trigger]To win[/trigger] tenetur a sapiente delectus, ut aut reiciendis voluptatibus maiores alias consequatur aut perferendis doloribus asperiores repellat\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}