using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(.*?)""\:(http\S+?(?=\W+(?:$|\s))|http\S+)";
string substitution = @"[\1](\2)";
string input = @"Cqwertyuioy - Lasgfdf Sddgfdds (Dsajjsa Vsjsjk Osaskgkk Spfs) ""link"":http://www.youtube.com/watch?v=aQjkOmzQ8RT";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}