$re = '/"(.*?)"\:(http\S+?(?=\W+(?:$|\s))|http\S+)/m';
$str = 'Cqwertyuioy - Lasgfdf Sddgfdds (Dsajjsa Vsjsjk Osaskgkk Spfs) "link":http://www.youtube.com/watch?v=aQjkOmzQ8RT';
$subst = "[\1](\2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;