import re
regex = re.compile(r"\"(.*?)\"\:(http\S+?(?=\W+(?:$|\s))|http\S+)", flags=re.MULTILINE)
test_str = "Cqwertyuioy - Lasgfdf Sddgfdds (Dsajjsa Vsjsjk Osaskgkk Spfs) \"link\":http://www.youtube.com/watch?v=aQjkOmzQ8RT"
subst = "[\\1](\\2)"
result = regex.sub(subst, test_str)
if result:
print(result)