import Foundation
let pattern = #""(.*?)"\:(http\S+?(?=\W+(?:$|\s))|http\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Cqwertyuioy - Lasgfdf Sddgfdds (Dsajjsa Vsjsjk Osaskgkk Spfs) "link":http://www.youtube.com/watch?v=aQjkOmzQ8RT"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\1](\2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)