import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]+[\\s]+(?:((static|virtual)[\\s]+))?[a-zA-Z<>0-9]+[\\s]+)(([a-zA-Z<>0-9]+)[\\s]+(.+))";
final String string = "public virtual Guid Id { get; set; }\n"
+ "public long NumericId { get; set; }\n"
+ "public Guid AccountId { get; set; }\n"
+ "public string AccountCode { get; set; }\n"
+ "public List<GroupDto> Groups { get; private set; }\n"
+ "public Direction Direction { get; set; }";
final String subst = "info.$5 = source.$5;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}