const regex = /([a-zA-Z]+[\s]+(?:((static|virtual)[\s]+))?[a-zA-Z<>0-9]+[\s]+)(([a-zA-Z<>0-9]+)[\s]+(.+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]+[\\s]+(?:((static|virtual)[\\s]+))?[a-zA-Z<>0-9]+[\\s]+)(([a-zA-Z<>0-9]+)[\\s]+(.+))', 'g')
const str = `public virtual Guid Id { get; set; }
public long NumericId { get; set; }
public Guid AccountId { get; set; }
public string AccountCode { get; set; }
public List<GroupDto> Groups { get; private set; }
public Direction Direction { get; set; }`;
const subst = `info.$5 = source.$5;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);