# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z]+[\s]+(?:((static|virtual)[\s]+))?[a-zA-Z<>0-9]+[\s]+)(([a-zA-Z<>0-9]+)[\s]+(.+))"
test_str = ("public virtual Guid Id { get; set; }\n"
"public long NumericId { get; set; }\n"
"public Guid AccountId { get; set; }\n"
"public string AccountCode { get; set; }\n"
"public List<GroupDto> Groups { get; private set; }\n"
"public Direction Direction { get; set; }")
subst = "info.$5 = source.$5;"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.