use strict;
my $str = 'public virtual Guid Id { get; set; }
public long NumericId { get; set; }
public Guid AccountId { get; set; }
public string AccountCode { get; set; }
public List<GroupDto> Groups { get; private set; }
public Direction Direction { get; set; }';
my $regex = qr/([a-zA-Z]+[\s]+(?:((static|virtual)[\s]+))?[a-zA-Z<>0-9]+[\s]+)(([a-zA-Z<>0-9]+)[\s]+(.+))/p;
my $subst = 'info.$5 = source.$5;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";