re = /([a-zA-Z]+[\s]+(?:((static|virtual)[\s]+))?[a-zA-Z<>0-9]+[\s]+)(([a-zA-Z<>0-9]+)[\s]+(.+))/
str = 'public virtual Guid Id { get; set; }
public long NumericId { get; set; }
public Guid AccountId { get; set; }
public string AccountCode { get; set; }
public List<GroupDto> Groups { get; private set; }
public Direction Direction { get; set; }'
subst = 'info.$5 = source.$5;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result