import Foundation
let pattern = #"([a-zA-Z]+[\s]+(?:((static|virtual)[\s]+))?[a-zA-Z<>0-9]+[\s]+)(([a-zA-Z<>0-9]+)[\s]+(.+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
public virtual Guid Id { get; set; }
public long NumericId { get; set; }
public Guid AccountId { get; set; }
public string AccountCode { get; set; }
public List<GroupDto> Groups { get; private set; }
public Direction Direction { get; set; }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"info.$5 = source.$5;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)