#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)advertorials\/?(?:(?!version)(.*))"
Local $sString = "domain.com/advertorials/version1?test=true" & @CRLF & _
"" & @CRLF & _
"domain.com/advertorials" & @CRLF & _
"domain.com/advertorials?test=true" & @CRLF & _
"domain.com/advertorials/" & @CRLF & _
"domain.com/advertorials/?test=true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")