import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "advertorials\\/?(?:(?!version)(.*))";
final String string = "domain.com/advertorials/version1?test=true\n\n"
+ "domain.com/advertorials\n"
+ "domain.com/advertorials?test=true\n"
+ "domain.com/advertorials/\n"
+ "domain.com/advertorials/?test=true";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}