const regex = /advertorials\/?(?:(?!version)(.*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('advertorials\\\/?(?:(?!version)(.*))', 'gm')
const str = `domain.com/advertorials/version1?test=true
domain.com/advertorials
domain.com/advertorials?test=true
domain.com/advertorials/
domain.com/advertorials/?test=true`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}