$re = '/advertorials\/?(?:(?!version)(.*))/m';
$str = 'domain.com/advertorials/version1?test=true
domain.com/advertorials
domain.com/advertorials?test=true
domain.com/advertorials/
domain.com/advertorials/?test=true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);