re = /advertorials\/?(?:(?!version)(.*))/m
str = 'domain.com/advertorials/version1?test=true
domain.com/advertorials
domain.com/advertorials?test=true
domain.com/advertorials/
domain.com/advertorials/?test=true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end