using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"advertorials\/?(?:(?!version)(.*))";
string input = @"domain.com/advertorials/version1?test=true
domain.com/advertorials
domain.com/advertorials?test=true
domain.com/advertorials/
domain.com/advertorials/?test=true";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}