package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^/\d]*\d[^/]*`)
var str = `/first/12ab34/B1a234/12B3a/1234/second/A789B-89d`
var substitution = "*"
fmt.Println(re.ReplaceAllString(str, substitution))
}