// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^/\d]*\d[^/]*").unwrap();
let string = "/first/12ab34/B1a234/12B3a/1234/second/A789B-89d";
let substitution = "*";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}