use strict;
my $str = '/first/12ab34/B1a234/12B3a/1234/second/A789B-89d';
my $regex = qr/[^/\d]*\d[^/]*/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";