import re
regex = re.compile(r"[^/\d]*\d[^/]*", flags=re.MULTILINE)
test_str = "/first/12ab34/B1a234/12B3a/1234/second/A789B-89d"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)