$re = '/[^/\d]*\d[^/]*/m';
$str = '/first/12ab34/B1a234/12B3a/1234/second/A789B-89d';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;