const regex = new RegExp('[^/\\d]*\\d[^/]*', 'gm')
const str = `/first/12ab34/B1a234/12B3a/1234/second/A789B-89d`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);