# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/&.*?\;//gm;t' <<< "“ ”9 9s asd sa das d as d asd as dsa sad asd as da sdas d “ ” "