import re
regex = re.compile(r"&.*?\;", flags=re.MULTILINE)
test_str = "“ ”9 9s asd sa das d as d asd as dsa sad asd as da sdas d “ ” "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)