#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)/\*((?!\*/).)+\\abc.*"
Local $sString = "/*=================================================*" & @CRLF & _
"* THIS IS NOT THE COMMENT I WANT" & @CRLF & _
"*===============================================*/" & @CRLF & _
"" & @CRLF & _
"/* THIS IS THE COMMENT I WANT." & @CRLF & _
"* It should be able to have special characters like /,*." & @CRLF & _
"* \\abc" & @CRLF & _
"*/" & @CRLF & _
"TEST(foo,bar){" & @CRLF & _
" ..." & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")