using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)/\*((?!\*/).)+\\abc.*";
string input = @"/*=================================================*
* THIS IS NOT THE COMMENT I WANT
*===============================================*/
/* THIS IS THE COMMENT I WANT.
* It should be able to have special characters like /,*.
* \\abc
*/
TEST(foo,bar){
...
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}