re = /(?s)\/\*((?!\*\/).)+\\abc.*/m
str = '/*=================================================*
* THIS IS NOT THE COMMENT I WANT
*===============================================*/
/* THIS IS THE COMMENT I WANT.
* It should be able to have special characters like /,*.
* \\\\abc
*/
TEST(foo,bar){
...
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end