$re = '/(?s)/\*((?!\*/).)+\\\\abc.*/m';
$str = '/*=================================================*
* THIS IS NOT THE COMMENT I WANT
*===============================================*/
/* THIS IS THE COMMENT I WANT.
* It should be able to have special characters like /,*.
* \\\\abc
*/
TEST(foo,bar){
...
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);