import re
regex = re.compile(r"(?s)/\*((?!\*/).)+\\abc.*", flags=re.MULTILINE)
test_str = ("/*=================================================*\n"
"* THIS IS NOT THE COMMENT I WANT\n"
"*===============================================*/\n\n"
"/* THIS IS THE COMMENT I WANT.\n"
"* It should be able to have special characters like /,*.\n"
"* \\\\abc\n"
"*/\n"
"TEST(foo,bar){\n"
" ...\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")