import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)/\\*((?!\\*/).)+\\\\abc.*";
final String string = "/*=================================================*\n"
+ "* THIS IS NOT THE COMMENT I WANT\n"
+ "*===============================================*/\n\n"
+ "/* THIS IS THE COMMENT I WANT.\n"
+ "* It should be able to have special characters like /,*.\n"
+ "* \\\\abc\n"
+ "*/\n"
+ "TEST(foo,bar){\n"
+ " ...\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}