using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]{1,}?[_-]?[a-z0-9]{1,}?\@[a-z0-9]{1,}?\-?[a-z0-9]{1,}?\.[a-z]{2,}$";
string input = @"mymail@site.ru
my-mail@site.ru
-mymail@site.ru
mymail-@site.ru
my---mail@site.ru
my--mail---test@site.com
mail@-site-.ru
mymail@site.__
mail@site.r
a@b.moscow
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}