re = /^[a-z0-9]{1,}?[_-]?[a-z0-9]{1,}?\@[a-z0-9]{1,}?\-?[a-z0-9]{1,}?\.[a-z]{2,}$/m
str = 'mymail@site.ru
my-mail@site.ru
-mymail@site.ru
mymail-@site.ru
my---mail@site.ru
my--mail---test@site.com
mail@-site-.ru
mymail@site.__
mail@site.r
a@b.moscow
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end