use strict;
my $str = 'mymail@site.ru
my-mail@site.ru
-mymail@site.ru
mymail-@site.ru
my---mail@site.ru
my--mail---test@site.com
mail@-site-.ru
mymail@site.__
mail@site.r
a@b.moscow
';
my $regex = qr/^[a-z0-9]{1,}?[_-]?[a-z0-9]{1,}?\@[a-z0-9]{1,}?\-?[a-z0-9]{1,}?\.[a-z]{2,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}